A Cars forum. AutoBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » AutoBanter forum » Auto makers » Saturn
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

96 SL2 Post-repair problem



 
 
Thread Tools Display Modes
  #1  
Old March 3rd 05, 03:24 AM
Fantine
external usenet poster
 
Posts: n/a
Default 96 SL2 Post-repair problem

I have a 96 SL2 that drives fine and has had very few problems over the
years. Got SES light, brought it in to a local and (supposedly) reputable
repair shop. Ended up having to replace the valve gasket cover. While the
car was there, so we decided to get some maintenance done because the car is
very low-mileage and we can definitely get more years from it. So, we got a
maintenance tune-up (including spark plugs), the ATF replaced, cooling
system flushed, and something called an air induction and fuel system
service (my hubbie agreed to that -- bye, bye tax refund!).

OK, we picked up the car right at the end of the day and drive it home.
Now, for the first time, the car is hesitating when we accelerate from a
stop and seems to be idling slightly faster than before. I'm going to
bring the car back to the shop tomorrow or Friday, but I'd like to go there
knowing what they did to create a problem that did not exist before, so that
they can't say it's something new. So, any suggestions? Thanks for your
help.


Ads
  #2  
Old March 3rd 05, 03:23 PM
B. Peg
external usenet poster
 
Posts: n/a
Default

I don't know how a SES light could point to a valve cover gasket. I'm also
thinking they did something else (like trying to degunk the EGR valve) and
messing it up.

B~



  #3  
Old March 3rd 05, 03:28 PM
Fantine
external usenet poster
 
Posts: n/a
Default

Wonderful. I picked this place because it got good ratings from AAA and
local magazines. So much for that!
I had to get the EGR valve replaced a few years ago, and the car's not
behaving like it did when that valve went bad.

"B. Peg" > wrote in message
...
>I don't know how a SES light could point to a valve cover gasket. I'm also
>thinking they did something else (like trying to degunk the EGR valve) and
>messing it up.
>
> B~
>
>
>



  #4  
Old March 3rd 05, 03:36 PM
Bob Shuman
external usenet poster
 
Posts: n/a
Default

I agree the valve cover gasket would not likely set a fault code. It would
just leak some oil and cause a mess. Sounds like they messed something else
up. Take it back and get it fixed, then never return there.

Bob

"B. Peg" > wrote in message
...
> I don't know how a SES light could point to a valve cover gasket. I'm

also
> thinking they did something else (like trying to degunk the EGR valve) and
> messing it up.
>
> B~
>
>
>



  #5  
Old March 3rd 05, 03:41 PM
Fantine
external usenet poster
 
Posts: n/a
Default

Well, the code supposedly, IIRC, was that one of the cylinders was not
firing, which they said was caused by the leaking oil. Does that make more
sense?

"Bob Shuman" > wrote in message
...
>I agree the valve cover gasket would not likely set a fault code. It would
> just leak some oil and cause a mess. Sounds like they messed something
> else
> up. Take it back and get it fixed, then never return there.
>
> Bob
>
> "B. Peg" > wrote in message
> ...
>> I don't know how a SES light could point to a valve cover gasket. I'm

> also
>> thinking they did something else (like trying to degunk the EGR valve)
>> and
>> messing it up.
>>
>> B~
>>
>>
>>

>
>



  #6  
Old March 3rd 05, 10:38 PM
Box134
external usenet poster
 
Posts: n/a
Default

Sounds like total rubbish. Whoever said that is a complete BSer. Besides,
you'd need to add freaking quarts of oil.

I think the best thing is to take it to a dealer. May be easy to say,
perhaps you don't have one near.

I also have a 96 SL2, low mileage, 104,000 km. I think here the ATF and
coolant are done at the 100,000 km mark. In your case I'm not sure if that's
early or late. Maybe more unnecessary maintenance.

"Fantine" > wrote in message
...
> Well, the code supposedly, IIRC, was that one of the cylinders was not
> firing, which they said was caused by the leaking oil. Does that make
> more sense?



  #7  
Old March 4th 05, 12:14 AM
Fantine
external usenet poster
 
Posts: n/a
Default

The reason we didn't take it to the Saturn dealer is that the nearest one is
a good 40 minutes away, more during rush hour. In any event, the problem
was found to be corrosion on the coil tower, and the shop owner said the
tech should have noticed it yesterday, but didn't. He was very apologetic
about the whole situation. They fixed it, and now the car runs smoothly
again. I did have to take the day off from work to deal with it, but the
good news is that, after dealing with the shop, I had the time to go see The
Aviator, which was simply fantastic.
Thanks for all the help, everyone. I appreciate it greatly.

"Box134" > wrote in message
...
> Sounds like total rubbish. Whoever said that is a complete BSer. Besides,
> you'd need to add freaking quarts of oil.
>
> I think the best thing is to take it to a dealer. May be easy to say,
> perhaps you don't have one near.
>
> I also have a 96 SL2, low mileage, 104,000 km. I think here the ATF and
> coolant are done at the 100,000 km mark. In your case I'm not sure if
> that's early or late. Maybe more unnecessary maintenance.
>
> "Fantine" > wrote in message
> ...
>> Well, the code supposedly, IIRC, was that one of the cylinders was not
>> firing, which they said was caused by the leaking oil. Does that make
>> more sense?

>
>



  #8  
Old March 4th 05, 01:06 AM
Box134
external usenet poster
 
Posts: n/a
Default

Great! Glad you had a good outcome. Yeah, corrosion on the coil tower sounds
more likely than a river of oil flowing into a cylinder. I suppose the shop
didn't mention that again, hoping no one would remember.

I don't know about The Aviator though! From the previews it looked like it
was half CGI. Just doesn't look right to me.

"Fantine" > wrote in message
...
> The reason we didn't take it to the Saturn dealer is that the nearest one
> is a good 40 minutes away, more during rush hour. In any event, the
> problem was found to be corrosion on the coil tower, and the shop owner
> said the tech should have noticed it yesterday, but didn't.



  #9  
Old March 4th 05, 01:13 AM
Fantine
external usenet poster
 
Posts: n/a
Default

OT: There wasn't too much CGI, and was there was was fine. The big plane
crash was absolutely terrifying. DiCaprio was superb, the best performance
I've ever seen from him. Who knew he had it in him!

"Box134" > wrote in message
...
> Great! Glad you had a good outcome. Yeah, corrosion on the coil tower
> sounds more likely than a river of oil flowing into a cylinder. I suppose
> the shop didn't mention that again, hoping no one would remember.
>
> I don't know about The Aviator though! From the previews it looked like it
> was half CGI. Just doesn't look right to me.
>
> "Fantine" > wrote in message
> ...
>> The reason we didn't take it to the Saturn dealer is that the nearest one
>> is a good 40 minutes away, more during rush hour. In any event, the
>> problem was found to be corrosion on the coil tower, and the shop owner
>> said the tech should have noticed it yesterday, but didn't.

>
>



  #10  
Old March 4th 05, 02:45 AM
David Teichholtz
external usenet poster
 
Posts: n/a
Default


"Fantine" > wrote in message
...
> Wonderful. I picked this place because it got good ratings from AAA

and
> local magazines. So much for that!


A local shop tried to rip off a friend of mine for a new transmission.
Luckily he called me and I was able to diagnose the problem as two 75 cent
bushings. When my friend went back and asked the shop to install the
bushings (don't ask, loooong story..) the shop refused, saying "We stand
behind our diagnosis, you need a new transmission". I put the bushings in
for him, this was about 2 years ago, transmission is fine.

Got an advertisement from the rip off shop last week, they are a "Top AAA"
recommended shop.



 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rec.autos.makers.chrysler FAQ, Part 1/6 Dr. David Zatz Chrysler 10 December 2nd 04 06:19 AM
New *FREE* Corvette Discussion Forum JLA ENTERPRISES TECHNOLOGIES INTEGRATION Corvette 12 November 30th 04 07:36 PM
rec.autos.makers.chrysler FAQ, Part 1/6 Dr. David Zatz Chrysler 10 November 16th 04 06:28 AM


All times are GMT +1. The time now is 11:00 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2004-2020 AutoBanter.
The comments are property of their posters.