A Cars forum. AutoBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » AutoBanter forum » Auto makers » Mazda
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Left turn signal not working, but can't seem to fix it



 
 
Thread Tools Display Modes
  #1  
Old January 29th 18, 11:25 PM posted to rec.autos.makers.mazda.miata
[email protected]
external usenet poster
 
Posts: 1
Default Left turn signal not working, but can't seem to fix it

I have a 2010 E450 and the left front turn signal is not working. In the dash it blinks fast. The rear light blinks but not the front one. The bulb is good. Can the relay single out just one light?
>
> Any suggestions as to what this might be or what to do next?


Ads
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 Dodge Caravan left turn signal not working accordion gal Dodge 2 July 21st 09 03:16 AM
01 Civic Front Turn Signal Not Working, But Lights On [email protected] Honda 1 May 25th 08 04:38 PM
Damn turn signal on 98 Explorer stopped working... Northstar Ford Explorer 1 September 22nd 06 04:03 AM
Left LoBeam Out, Turn Signal Warning Signal On Ted Borck Jeep 5 November 25th 05 09:05 PM
turn signal and hazzard not working all other lights work ezbob2 Ford Explorer 0 October 18th 05 08:13 PM


All times are GMT +1. The time now is 03:00 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2004-2018 AutoBanter.
The comments are property of their posters.