A Cars forum. AutoBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » AutoBanter forum » Auto newsgroups » Technology
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Engine Miss in Blazer S10 4.3 Vortec



 
 
Thread Tools Display Modes
  #1  
Old June 20th 07, 10:12 PM posted to rec.autos.tech
packard
external usenet poster
 
Posts: 2
Default Engine Miss in Blazer S10 4.3 Vortec

My 1993 S10 Blazer is running low speed rough idle. I replaced the
rotor and cap, spark plugs (wires are 3 years old), cleaned the EGR
valve and put a new gasket in the EGR valve.

Can anyone give me an idea of what can be causing the problem?

Ads
  #2  
Old June 20th 07, 11:02 PM posted to rec.autos.tech
dahpater
external usenet poster
 
Posts: 118
Default Engine Miss in Blazer S10 4.3 Vortec

On Jun 20, 5:12 pm, packard > wrote:
> My 1993 S10 Blazer is running low speed rough idle. I replaced the
> rotor and cap, spark plugs (wires are 3 years old), cleaned the EGR
> valve and put a new gasket in the EGR valve.
>
> Can anyone give me an idea of what can be causing the problem?


Clean the throttle plate.
Replace the fuel filter and check the fuel pressure.

  #3  
Old June 20th 07, 11:15 PM posted to rec.autos.tech
packard
external usenet poster
 
Posts: 2
Default Engine Miss in Blazer S10 4.3 Vortec

On Jun 20, 6:02 pm, dahpater > wrote:
> On Jun 20, 5:12 pm, packard > wrote:
>
> > My 1993S10Blazeris running low speed rough idle. I replaced the
> > rotor and cap, spark plugs (wires are 3 years old), cleaned the EGR
> > valve and put a new gasket in the EGR valve.

>
> > Can anyone give me an idea of what can be causing the problem?

>
> Clean the throttle plate.
> Replace the fuel filter and check the fuel pressure.


Thank you. I cleaned the throttle plate. I will replace the fuel
filter. How do I check the fuel pressure?

  #4  
Old June 21st 07, 12:16 PM posted to rec.autos.tech
AWN
external usenet poster
 
Posts: 41
Default Engine Miss in Blazer S10 4.3 Vortec

You will see a small shraeder valve behind the air plenum to the right of
the distributor (right behind cyl #5 I think). You need a fuel pressure
gauge to do this properly. I'm going to guess that it's either a bad fuel
pump or pulsator OR the dreader fuel spider under the plenum. If you want a
quick check, open the throttle plate and stick in a mini light and mirror -
look for very clean, shiny spots to the left and right side. If you have
gas smell and a clean spot to the left, you may be able to replace a fuel
pressure regulator and be back in business. If the leak is on the right,
you likely need new fuel inlet lines (aka, 'nut kit'). If it seems that
it's leaking all over and you just want to do the job properly, get both the
fuel spider and nut kit from either Linder Tech or an AC Delco dealer. The
first step is to ensure that you're getting 58-62psi consistently with the
key on engine off. It should drop to maybe 52psi when the engine is
running. If that pressure doesn't hold for more than 10min-an hour, you
have a leak in the fuel system that needs to be fixed. Can you smell fuel
when exiting or entering the vehicle?

Thanks and let us know. I just went through this and I'm not in the clear
after replacing the pump, fuel spider and nut kit. I also did the cap,
rotor, wires, cleaned the EGA, IAC, MAP replaced, etc... Don't throw away
money till you check your fuel pressure. Have the codes shown that cyl #1
is missing or is it random? If it's cyl#1, it's likely a leak on the fuel
inlet side because fuel can leak down into the cyl easily on that side (in
my experience).


Andrew.



in article , dahpater at
wrote on 6/20/07 6:02 PM:

> On Jun 20, 5:12 pm, packard > wrote:
>> My 1993 S10 Blazer is running low speed rough idle. I replaced the
>> rotor and cap, spark plugs (wires are 3 years old), cleaned the EGR
>> valve and put a new gasket in the EGR valve.
>>
>> Can anyone give me an idea of what can be causing the problem?

>
> Clean the throttle plate.
> Replace the fuel filter and check the fuel pressure.


  #5  
Old June 21st 07, 10:38 PM posted to rec.autos.tech
bsquared
external usenet poster
 
Posts: 5
Default Engine Miss in Blazer S10 4.3 Vortec


packard wrote:
> My 1993 S10 Blazer is running low speed rough idle. I replaced the
> rotor and cap, spark plugs (wires are 3 years old), cleaned the EGR
> valve and put a new gasket in the EGR valve.
>
> Can anyone give me an idea of what can be causing the problem?


All of the previous advice is dead on. I have my own story with a '93
lumina. I did all of those things or what is realtive on my car. Ended
up being the Computer how ever. How to check, real scientific method
of finding roughly where it is locate, possibly above passenger side
wheel well, and giving a good thump in that area. It should kill the
vehicle immediately. Also my experience was when I started having
problems it would run stupid and sometimes run fine. Go to a GM dealer
for a rebuild if that IS the case. You can get a new eprom chip and
computer for almost half of what you can a computer from Autozone or
where ever. Don't know if this will help but it is worth a try if your
still in the "testing" phase and don't want to spend money you don't
have to. Price for computer and eprom for the Lumina from GM $280, but
after wasting $500 on things that were not necessary that's fairly
cheap. Good luck.

 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Does vortec engine mean good? [email protected] Technology 33 October 29th 05 03:06 PM
Please help. 91 nissan maxima GXE engine miss [email protected] Technology 6 June 28th 05 04:11 PM
95 chevy blazer vortec 4.3 otay 4x4 1 June 3rd 05 10:09 PM
97 Blazer 4.3 vortec Need help with a problem Don1974 4x4 1 January 19th 05 12:37 AM
92 DOHC SL2 engine miss Rogers Saturn 2 December 30th 04 12:30 AM


All times are GMT +1. The time now is 03:26 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2004-2014 AutoBanter.
The comments are property of their posters.